Foren-Ăśbersicht Letzte Topics Registrieren Anmelden

PureBasic-Lounge.com :: Allgemein :: OpenGL - Subsystem

Hier kannst du wegen allen möglichen Themen rund um die Programmierung in PureBasic Fragen stellen, für welche kein Unterforum existiert.
Bitte schreibt an den Kopf euerer Sources die PB Version.

Moderator: Moderatoren

OpenGL - Subsystem

Beitragvon Hroudtwolf » 19.11.2012, 14:18

Hi,

Ich wollte eben mal wieder was Kleines in Purebasic zaubern, als mir auffiel dass meine Direct3D Sachen unter Linux gar nicht funktionieren.
Da erinnerte ich mich, dass es doch mal das OpenGL-Subsystem gab. Ich fand es jedoch nicht im Subsystem-Ordner.
Gibts das nicht mehr? Falls doch, woher bekomm ichs?

Liebe GrĂĽsse
Wolf
Benutzeravatar
Hroudtwolf
Administrator
 
Beiträge: 9710
Registriert: 02.02.2005, 02:39
  • Website
  • ICQ
  • Position des Users auf der Mitgliederkarte

Re: OpenGL - Subsystem

Beitragvon helpy » 19.11.2012, 14:34

Unter Windows im PB-Verzeichnis von PureBasic 5.00 ==> [PureBasic]\SubSystems\OpenGL\PureLibraries

==> siehe Screenshot im Anhang
Dateianhänge
pb-subsystem-opengl.png
Screenshot Verzeichnisstruktur von PB 5.00 Subsystem/OpenGL
pb-subsystem-opengl.png (14.16 KiB) 1113-mal betrachtet
Benutzeravatar
helpy
JuniorUser
 
Beiträge: 137
Registriert: 28.06.2006, 08:15
Wohnort: In Niederbayern ;-)

Re: OpenGL - Subsystem

Beitragvon Hroudtwolf » 19.11.2012, 14:36

Hi,

Ich hab aber Linux. :)

LG
Wolf
Benutzeravatar
Hroudtwolf
Administrator
 
Beiträge: 9710
Registriert: 02.02.2005, 02:39
  • Website
  • ICQ
  • Position des Users auf der Mitgliederkarte

Re: OpenGL - Subsystem

Beitragvon bembulak » 19.11.2012, 14:37

Trag' einfach mal im Subsystem (Compilereinstellungen) opengl ein und fertig.
Sollte gehen!
MFG
bembu
Benutzeravatar
bembulak
Ehrenmitglied
Ehrenmitglied
 
Beiträge: 3168
Registriert: 18.07.2005, 11:44

Re: OpenGL - Subsystem

Beitragvon Hroudtwolf » 19.11.2012, 14:39

Hi,

In diesem Fall bekomme ich von der IDE die Meldung "The following subsystem cannot be found: opengl".
Das Gleiche bei allen Schreibweisen des Wortes.
Auch im Subsystems-Ordner meiner PB-Installation ist ein OpenGL-Ordner.

LG
Wolf

PS: Auch ohne Subsys-Angabe klappts nicht.
Da wirft die IDE-Exceptions in die Console wie "Broken communication pipe.testXlib: extension "RANDR" missing on display ":0.0"."
Benutzeravatar
Hroudtwolf
Administrator
 
Beiträge: 9710
Registriert: 02.02.2005, 02:39
  • Website
  • ICQ
  • Position des Users auf der Mitgliederkarte

Re: OpenGL - Subsystem

Beitragvon bembulak » 19.11.2012, 15:33

Sag, kann es sein, dass du eine fehlerhafte PB-Installation hast & / ! Ubuntu verwendest? Ich hatte in letzter Zeit mit Ubuntu immer wieder Probleme. Darum hab' ich's auch gleich wieder von der Platte geputzt. Ah, wenn ich's genau nehme, habe ich seit den ganzen Compositin-WMs, Waylands, Unity, ... immer mal wieder Probleme mit PB unter Linux (nach dem Schließen eines Screens ist die Auflösung im Eimer, ...)

Einzig Linux Mint mit LXDE und XFCE funktionieren einwandfrei.
MFG
bembu
Benutzeravatar
bembulak
Ehrenmitglied
Ehrenmitglied
 
Beiträge: 3168
Registriert: 18.07.2005, 11:44

Nächste

ZurĂĽck zu PureBasic-Lounge.com :: Allgemein

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste

cron